fontawesome-4.7.0.ebuild 603 B

123456789101112131415161718192021222324252627282930313233
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit font
  5. REPO_PN="Font-Awesome"
  6. DESCRIPTION="The iconic font"
  7. HOMEPAGE="http://fontawesome.io"
  8. SRC_URI="https://github.com/FortAwesome/${REPO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
  9. LICENSE="CC-BY-3.0 OFL-1.1"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~arm ~arm64 ~x86"
  12. IUSE="+otf +ttf"
  13. REQUIRED_USE="|| ( otf ttf )"
  14. DEPEND=""
  15. RDEPEND=""
  16. S="${WORKDIR}/${REPO_PN}-${PV}"
  17. FONT_S="${S}/fonts"
  18. FONT_SUFFIX=""
  19. src_configure() {
  20. use otf && FONT_SUFFIX+="otf "
  21. use ttf && FONT_SUFFIX+="ttf "
  22. }