wqy-zenhei-0.9.46.ebuild 1.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. DISABLE_AUTOFORMATTING=true
  5. inherit font readme.gentoo
  6. DESCRIPTION="WenQuanYi Hei-Ti Style (sans-serif) Chinese outline font"
  7. HOMEPAGE="http://wenq.org/wqy2/index.cgi?ZenHei"
  8. SRC_URI="mirror://sourceforge/project/wqy/${PN}-snapshot/${PV}-May/${P}-May.tar.bz2"
  9. LICENSE="GPL-2-with-font-exception"
  10. SLOT="0"
  11. KEYWORDS="amd64 arm ppc ppc64 x86 ~x86-fbsd"
  12. IUSE=""
  13. S="${WORKDIR}/${PN}"
  14. FONT_S="${S}"
  15. FONT_SUFFIX="ttc"
  16. FONT_CONF=(
  17. 43-wqy-zenhei-sharp.conf
  18. 44-wqy-zenhei.conf
  19. )
  20. # Only installs fonts
  21. RESTRICT="binchecks strip test"
  22. DOC_CONTENTS="This font installs two fontconfig configuration files.
  23. To activate preferred rendering, run:
  24. eselect fontconfig enable 44-wqy-zenhei.conf
  25. To make the font only use embedded bitmap fonts when available, run:
  26. eselect fontconfig enable 43-wqy-zenhei-sharp.conf"
  27. src_prepare() {
  28. epatch "${FILESDIR}/44-wqy-zenhei.conf.patch"
  29. }
  30. src_compile() {
  31. :
  32. }
  33. src_install() {
  34. font_src_install
  35. readme.gentoo_create_doc
  36. }
  37. pkg_postinst() {
  38. unset FONT_CONF # override default message
  39. font_pkg_postinst
  40. readme.gentoo_pkg_postinst
  41. }