apngdis-2.7.ebuild 640 B

1234567891011121314151617181920212223242526272829303132333435
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. inherit toolchain-funcs eutils
  5. DESCRIPTION="extract PNG frames from an APNG"
  6. HOMEPAGE="https://sourceforge.net/projects/apngdis/"
  7. SRC_URI="mirror://sourceforge/${PN}/${PV}/${P}-src.zip"
  8. LICENSE="LGPL-2.1"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. IUSE=""
  12. RDEPEND="sys-libs/zlib
  13. media-libs/libpng:0="
  14. DEPEND="${RDEPEND}
  15. app-arch/unzip"
  16. S=${WORKDIR}
  17. src_prepare() {
  18. epatch "${FILESDIR}"/${PN}-2.6-makefile.patch
  19. epatch "${FILESDIR}"/${PN}-2.6-gcc-4.3.patch
  20. tc-export CXX
  21. }
  22. src_install() {
  23. dobin ${PN}
  24. dodoc readme.txt
  25. }