apngdis-2.8.ebuild 579 B

123456789101112131415161718192021222324252627282930313233
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit toolchain-funcs eutils
  5. DESCRIPTION="extract PNG frames from an APNG"
  6. HOMEPAGE="https://sourceforge.net/projects/apngdis/"
  7. SRC_URI="mirror://sourceforge/${PN}/${PV}/${P}-src.zip"
  8. LICENSE="LGPL-2.1"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. RDEPEND="sys-libs/zlib
  12. media-libs/libpng:0="
  13. DEPEND="${RDEPEND}
  14. app-arch/unzip"
  15. S=${WORKDIR}
  16. src_prepare() {
  17. epatch "${FILESDIR}"/${P}-makefile.patch
  18. tc-export CXX
  19. }
  20. src_install() {
  21. dobin ${PN}
  22. dodoc readme.txt
  23. }