autotrace-0.31.1-r8.ebuild 1.5 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit autotools eutils
  5. _dpatch=15
  6. DESCRIPTION="A program for converting bitmaps to vector graphics"
  7. HOMEPAGE="http://packages.qa.debian.org/a/autotrace.html http://autotrace.sourceforge.net/"
  8. SRC_URI="mirror://debian/pool/main/a/${PN}/${PN}_${PV}.orig.tar.gz
  9. mirror://debian/pool/main/a/${PN}/${PN}_${PV}-${_dpatch}.diff.gz"
  10. LICENSE="GPL-2 LGPL-2.1"
  11. SLOT="0"
  12. KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
  13. IUSE="+imagemagick static-libs"
  14. RDEPEND="media-libs/libexif:=
  15. media-libs/libpng:0=
  16. >=media-libs/ming-0.4.2:=
  17. >=media-gfx/pstoedit-3.50:=
  18. imagemagick? ( >=media-gfx/imagemagick-6.6.2.5 )"
  19. DEPEND="${RDEPEND}
  20. virtual/pkgconfig"
  21. DOCS=( AUTHORS ChangeLog NEWS README )
  22. src_prepare() {
  23. epatch "${WORKDIR}"/${PN}_${PV}-${_dpatch}.diff
  24. epatch \
  25. "${FILESDIR}"/${P}-{m4,libpng14,pkgconfig}.patch \
  26. "${FILESDIR}"/${P}-swf-output.patch \
  27. "${FILESDIR}"/${P}-GetOnePixel.patch \
  28. "${FILESDIR}"/${P}-libpng-1.5.patch
  29. # Fix building on PowerPC with Altivec
  30. epatch "${FILESDIR}"/${P}-bool.patch
  31. # Addresses bug #466078
  32. epatch "${FILESDIR}"/${P}-CVE-2013-1953.patch
  33. # bug #613992
  34. epatch "${FILESDIR}"/${P}-CVE-2016-7392.patch
  35. sed -i -e 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:' configure.in || die #468496
  36. eautoreconf
  37. }
  38. src_configure() {
  39. econf \
  40. $(use_enable static-libs static) \
  41. $(use_with imagemagick magick) \
  42. --with-ming \
  43. --with-pstoedit
  44. }
  45. src_install() {
  46. default
  47. prune_libtool_files --all
  48. }