cellwriter-1.3.4.ebuild 619 B

123456789101112131415161718192021222324252627282930
  1. # Copyright 1999-2012 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=2
  4. DESCRIPTION="Grid-entry natural handwriting input panel"
  5. HOMEPAGE="http://risujin.org/cellwriter/"
  6. SRC_URI="http://pub.risujin.org/cellwriter/${P}.tar.gz"
  7. LICENSE="GPL-2"
  8. SLOT="0"
  9. KEYWORDS="amd64 ppc x86"
  10. IUSE="gnome"
  11. RDEPEND="x11-libs/libXtst
  12. >=x11-libs/gtk+-2.10:2
  13. gnome? ( gnome-base/libgnome )"
  14. DEPEND="${RDEPEND}
  15. virtual/pkgconfig
  16. x11-proto/inputproto"
  17. src_configure() {
  18. econf $(use_with gnome)
  19. }
  20. src_install() {
  21. emake DESTDIR="${D}" install || die
  22. dodoc AUTHORS ChangeLog NEWS README
  23. }