cellwriter-1.3.5.ebuild 718 B

1234567891011121314151617181920212223242526272829303132
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit gnome2-utils
  5. DESCRIPTION="Grid-entry natural handwriting input panel"
  6. HOMEPAGE="http://risujin.org/cellwriter/"
  7. SRC_URI="http://pub.risujin.org/cellwriter/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 ppc x86"
  11. IUSE=""
  12. RDEPEND="x11-libs/gtk+:2
  13. x11-libs/libX11
  14. x11-libs/libXtst"
  15. DEPEND="${RDEPEND}
  16. virtual/pkgconfig
  17. x11-proto/xproto"
  18. DOCS="AUTHORS ChangeLog README TODO" # NEWS is no-op
  19. src_prepare() {
  20. sed -i -e '/Encoding/d' ${PN}.desktop || die
  21. }
  22. pkg_preinst() { gnome2_icon_savelist; }
  23. pkg_postinst() { gnome2_icon_cache_update; }
  24. pkg_postrm() { gnome2_icon_cache_update; }