fbgrab-1.0-r2.ebuild 685 B

12345678910111213141516171819202122232425262728293031323334353637
  1. # Copyright 1999-2013 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils toolchain-funcs
  5. DESCRIPTION="Framebuffer screenshot utility"
  6. HOMEPAGE="http://hem.bredband.net/gmogmo/fbgrab/"
  7. SRC_URI="http://hem.bredband.net/gmogmo/${PN}/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~alpha amd64 arm ~hppa ~ia64 ppc ~ppc64 ~sparc x86"
  11. IUSE=""
  12. RDEPEND="media-libs/libpng
  13. sys-libs/zlib"
  14. DEPEND="${RDEPEND}"
  15. src_prepare() {
  16. epatch "${FILESDIR}/${P}-zlib_h.patch" \
  17. "${FILESDIR}/${P}-Makefile.patch"
  18. epatch_user
  19. }
  20. src_compile() {
  21. emake CC="$(tc-getCC)"
  22. }
  23. src_install() {
  24. dobin ${PN}
  25. newman ${PN}.1.man ${PN}.1
  26. }