feh-2.18.ebuild 1.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit eutils toolchain-funcs
  5. DESCRIPTION="A fast, lightweight imageviewer using imlib2"
  6. HOMEPAGE="http://feh.finalrewind.org/"
  7. SRC_URI="http://feh.finalrewind.org/${P}.tar.bz2"
  8. LICENSE="feh"
  9. SLOT="0"
  10. KEYWORDS="amd64 ~arm ~mips ppc ppc64 x86"
  11. IUSE="debug curl exif test xinerama"
  12. COMMON_DEPEND="media-libs/imlib2[X]
  13. >=media-libs/libpng-1.2:0=
  14. x11-libs/libX11
  15. curl? ( net-misc/curl )
  16. exif? ( media-libs/libexif )
  17. xinerama? ( x11-libs/libXinerama )"
  18. RDEPEND="${COMMON_DEPEND}
  19. virtual/jpeg:0"
  20. DEPEND="${COMMON_DEPEND}
  21. x11-libs/libXt
  22. x11-proto/xproto
  23. test? (
  24. >=dev-lang/perl-5.10
  25. dev-perl/Test-Command
  26. )"
  27. PATCHES=( "${FILESDIR}"/${PN}-2.6.2-debug-cflags.patch )
  28. pkg_setup() {
  29. use_feh() { usex $1 1 0; }
  30. fehopts=(
  31. DESTDIR="${D}"
  32. PREFIX="${EPREFIX}"/usr
  33. doc_dir='${main_dir}'/share/doc/${PF}
  34. example_dir='${main_dir}'/share/doc/${PF}/examples
  35. curl=$(use_feh curl)
  36. debug=$(use_feh debug)
  37. xinerama=$(use_feh xinerama)
  38. exif=$(use_feh exif)
  39. )
  40. }
  41. src_compile() {
  42. tc-export CC
  43. emake "${fehopts[@]}"
  44. }
  45. src_install() {
  46. emake "${fehopts[@]}" install
  47. }