123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990 |
- # Copyright 1999-2014 Gentoo Foundation
- # Distributed under the terms of the GNU General Public License v2
- EAPI="4"
- inherit rpm versionator multilib
- MY_PV="$(get_version_component_range 1-3)"
- MY_PVR="$(replace_version_separator 3 -)"
- DESCRIPTION="Epson Perfection V500 scanner plugin for SANE 'epkowa' backend"
- HOMEPAGE="http://download.ebz.epson.net/dsc/search/01/search/?OSC=LX"
- SRC_URI="
- x86? ( https://dev.gentoo.org/~flameeyes/avasys/${PN}/${MY_PV}/${PN}-${MY_PVR}.i386.rpm )
- amd64? ( https://dev.gentoo.org/~flameeyes/avasys/${PN}/${MY_PV}/${PN}-${MY_PVR}.x86_64.rpm )
- "
- LICENSE="AVASYS"
- SLOT="0"
- KEYWORDS="-* ~amd64 ~x86"
- IUSE=""
- DEPEND=">=media-gfx/iscan-2.21.0
- !!<media-gfx/iscan-plugin-gt-x770-2.1.2.1-r2"
- RDEPEND="${DEPEND}"
- S="${WORKDIR}"
- QA_PREBUILT="/opt/iscan/esci/libesint7C.so*"
- src_configure() { :; }
- src_compile() { :; }
- src_install() {
- # install scanner firmware
- insinto /usr/share/iscan
- doins "${WORKDIR}/usr/share/iscan/"*
- dodoc usr/share/doc/*/*
- # install scanner plugins
- exeinto /opt/iscan/esci
- doexe "${WORKDIR}/usr/$(get_libdir)/iscan/"*
- }
- pkg_setup() {
- basecmds=(
- "iscan-registry --COMMAND interpreter usb 0x04b8 0x0130 /opt/iscan/esci/libesint7C /usr/share/iscan/esfw7C.bin"
- )
- }
- pkg_postinst() {
- elog
- elog "Firmware file esfw41.bin for Epson Perfection V500"
- elog "has been installed in /usr/share/iscan."
- elog
- [[ -n ${REPLACING_VERSIONS} ]] && return
- # Needed for scanner to work properly.
- if [[ ${ROOT} == "/" ]]; then
- for basecmd in "${basecmds[@]}"; do
- eval ${basecmd/COMMAND/add}
- done
- else
- ewarn "Unable to register the plugin and firmware when installing outside of /."
- ewarn "execute the following command yourself:"
- for basecmd in "${basecmds[@]}"; do
- ewarn "${basecmd/COMMAND/add}"
- done
- fi
- }
- pkg_prerm() {
- [[ -n ${REPLACED_BY_VERSION} ]] && return
- if [[ ${ROOT} == "/" ]]; then
- for basecmd in "${basecmds[@]}"; do
- eval ${basecmd/COMMAND/remove}
- done
- else
- ewarn "Unable to de-register the plugin and firmware when installing outside of /."
- ewarn "execute the following command yourself:"
- for basecmd in "${basecmds[@]}"; do
- ewarn "${basecmd/COMMAND/remove}"
- done
- fi
- }
|