mscgen-0.20.ebuild 844 B

12345678910111213141516171819202122232425262728293031323334353637383940414243
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. inherit autotools
  5. DESCRIPTION="A message sequence chart generator"
  6. HOMEPAGE="http://www.mcternan.me.uk/mscgen/"
  7. SRC_URI="http://www.mcternan.me.uk/${PN}/software/${PN}-src-${PV}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 arm ppc ppc64 x86 ~x64-solaris"
  11. IUSE="png truetype"
  12. RDEPEND="png? ( media-libs/gd[png,truetype?] )"
  13. DEPEND="${RDEPEND}
  14. virtual/pkgconfig
  15. sys-devel/bison
  16. sys-devel/flex"
  17. # Workaround for bug #379279
  18. RESTRICT="test"
  19. src_prepare() {
  20. sed -i -e '/dist_doc_DATA/d' Makefile.am || die
  21. eautoreconf
  22. }
  23. src_configure() {
  24. local myconf
  25. if use png; then
  26. use truetype && myconf="--with-freetype"
  27. else
  28. myconf="--without-png"
  29. fi
  30. econf \
  31. --docdir="${EPREFIX}"/usr/share/doc/${PF} \
  32. ${myconf}
  33. }