pngcheck-2.3.0.ebuild 669 B

123456789101112131415161718192021222324252627282930
  1. # Copyright 1999-2012 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=2
  4. inherit toolchain-funcs
  5. DESCRIPTION="verifies the integrity of PNG, JNG and MNG files with internal checksums"
  6. HOMEPAGE="http://www.libpng.org/pub/png/apps/pngcheck.html"
  7. SRC_URI="mirror://sourceforge/png-mng/${P}.tar.gz"
  8. LICENSE="HPND GPL-2+"
  9. SLOT="0"
  10. KEYWORDS="amd64 x86"
  11. IUSE=""
  12. RDEPEND="sys-libs/zlib"
  13. DEPEND="${RDEPEND}"
  14. src_compile() {
  15. emake -f Makefile.unx \
  16. CC="$(tc-getCC)" \
  17. CFLAGS="${LDFLAGS} ${CFLAGS} -DUSE_ZLIB" \
  18. ZLIB="-lz" || die
  19. }
  20. src_install() {
  21. dobin png{check,split,-fix-IDAT-windowsize} || die
  22. dodoc CHANGELOG README
  23. }