pornview-0.2.2-r1.ebuild 974 B

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit gnome2-utils
  5. DESCRIPTION="Image viewer/manager with optional support for MPEG movies"
  6. HOMEPAGE="http://pornview.sourceforge.net"
  7. SRC_URI="https://dev.gentoo.org/~hasufell/distfiles/${P}.tar.xz
  8. mirror://github/gentoo/${PN}/${P}.tar.xz"
  9. LICENSE="GPL-2"
  10. SLOT="0"
  11. KEYWORDS="~amd64 -hppa ~ppc ~x86"
  12. IUSE="exif nls"
  13. RDEPEND="
  14. dev-libs/glib:2
  15. media-libs/libpng:0
  16. virtual/jpeg:*
  17. x11-libs/gdk-pixbuf:2
  18. x11-libs/gtk+:2
  19. x11-libs/libX11
  20. x11-libs/libXinerama
  21. exif? ( media-gfx/exiv2 )"
  22. DEPEND="${RDEPEND}
  23. virtual/pkgconfig
  24. nls? ( sys-devel/gettext )"
  25. src_configure() {
  26. econf \
  27. $(use_enable exif) \
  28. $(use_enable nls)
  29. }
  30. src_install() {
  31. default
  32. emake DESTDIR="${D}" desktopdir="/usr/share/applications" install
  33. }
  34. pkg_preinst() {
  35. gnome2_icon_savelist
  36. }
  37. pkg_postinst() {
  38. gnome2_icon_cache_update
  39. }
  40. pkg_postrm() {
  41. gnome2_icon_cache_update
  42. }