splash-themes-livecd-2005.0.ebuild 734 B

123456789101112131415161718192021222324252627282930
  1. # Copyright 1999-2013 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. MY_P="gentoo-livecd-${PV}"
  4. MY_REV="0.9.1"
  5. DESCRIPTION="Gentoo theme for gensplash consoles"
  6. HOMEPAGE="https://www.gentoo.org/"
  7. SRC_URI="https://dev.gentoo.org/~wolf31o2/sources/${PN}/${MY_P}-${MY_REV}.tar.bz2"
  8. SLOT=${PV}
  9. LICENSE="Artistic GPL-2 BitstreamVera"
  10. KEYWORDS="amd64 ~ppc x86"
  11. IUSE=""
  12. RESTRICT="binchecks strip"
  13. DEPEND=">=media-gfx/splashutils-0.9.1"
  14. S="${WORKDIR}/${MY_P}"
  15. src_unpack() {
  16. unpack ${A}
  17. cd "${S}"
  18. sed -i -e 's-/sbin/functions.sh-/etc/init.d/functions.sh-' scripts/rc_init-pre scripts/list_svc.sh
  19. }
  20. src_install() {
  21. dodir /etc/splash/livecd-${PV}
  22. cp -r "${S}"/* "${D}"/etc/splash/livecd-${PV}
  23. }