svg2rlg-0.3.ebuild 806 B

1234567891011121314151617181920212223242526272829303132333435363738
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. PYTHON_COMPAT=( python2_7 )
  5. inherit distutils-r1
  6. DESCRIPTION="python tool to convert SVG files to reportlab graphics"
  7. HOMEPAGE="https://code.google.com/p/svg2rlg/"
  8. SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
  9. LICENSE="BSD"
  10. SLOT="0"
  11. KEYWORDS="alpha amd64 arm hppa ppc ppc64 sparc x86"
  12. IUSE=""
  13. DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
  14. RDEPEND="${DEPEND}
  15. dev-python/reportlab[${PYTHON_USEDEP}]"
  16. PATCHES=(
  17. "${FILESDIR}/${PN}-issue-3.patch"
  18. "${FILESDIR}/${PN}-issue-6.patch"
  19. "${FILESDIR}/${PN}-issue-7.patch"
  20. )
  21. python_test() {
  22. ${EPYTHON} test_svg2rlg.py
  23. }
  24. python_prepare_all() {
  25. find -name '*.py' -exec sed -i 's:\r::' {} + || die
  26. distutils-r1_python_prepare_all
  27. }