audacious-plugins-3.1.ebuild 3.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. inherit eutils flag-o-matic
  5. MY_P="${P/_/-}"
  6. S="${WORKDIR}/${MY_P}"
  7. DESCRIPTION="Audacious Player - Your music, your way, no exceptions"
  8. HOMEPAGE="http://audacious-media-player.org/"
  9. SRC_URI="http://distfiles.atheme.org/${MY_P}.tar.bz2"
  10. LICENSE="GPL-2"
  11. SLOT="0"
  12. KEYWORDS="alpha amd64 hppa ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux"
  13. IUSE="aac adplug alsa aqua bs2b cdda cue ffmpeg flac fluidsynth gnome ipv6 jack
  14. lame libnotify libsamplerate midi mms mp3 mtp nls oss pulseaudio scrobbler sid sndfile vorbis wavpack"
  15. RDEPEND="app-arch/unzip
  16. >=dev-libs/dbus-glib-0.60
  17. dev-libs/libxml2:2
  18. media-libs/libmodplug
  19. ~media-sound/audacious-3.1
  20. >=net-libs/neon-0.26.4
  21. x11-libs/gtk+:3
  22. aac? ( >=media-libs/faad2-2.7 )
  23. adplug? ( >=dev-cpp/libbinio-1.4 )
  24. alsa? ( >=media-libs/alsa-lib-1.0.16 )
  25. bs2b? ( media-libs/libbs2b )
  26. cdda? ( >=media-libs/libcddb-1.2.1
  27. >=dev-libs/libcdio-0.79-r1 )
  28. cue? ( media-libs/libcue )
  29. ffmpeg? ( >=virtual/ffmpeg-0.7.3 )
  30. flac? ( >=media-libs/libvorbis-1.0
  31. >=media-libs/flac-1.2.1-r1 )
  32. fluidsynth? ( media-sound/fluidsynth )
  33. jack? ( >=media-libs/bio2jack-0.4
  34. media-sound/jack-audio-connection-kit )
  35. lame? ( media-sound/lame )
  36. libnotify? ( x11-libs/libnotify )
  37. libsamplerate? ( media-libs/libsamplerate )
  38. mms? ( >=media-libs/libmms-0.3 )
  39. mp3? ( >=media-sound/mpg123-1.12.1 )
  40. mtp? ( media-libs/libmtp )
  41. pulseaudio? ( >=media-sound/pulseaudio-0.9.3 )
  42. scrobbler? ( net-misc/curl )
  43. sid? ( >=media-libs/libsidplay-2.1.1-r2 )
  44. sndfile? ( >=media-libs/libsndfile-1.0.17-r1 )
  45. vorbis? ( >=media-libs/libvorbis-1.2.0
  46. >=media-libs/libogg-1.1.3 )
  47. wavpack? ( >=media-sound/wavpack-4.50.1-r1 )"
  48. DEPEND="${RDEPEND}
  49. nls? ( dev-util/intltool )
  50. virtual/pkgconfig"
  51. mp3_warning() {
  52. if ! use mp3 ; then
  53. ewarn "MP3 support is optional, you may want to enable the mp3 USE-flag"
  54. fi
  55. }
  56. src_configure() {
  57. mp3_warning
  58. # Turn "-z defs" into "-Wl,-z,defs" because some versions of gcc don't like
  59. # it (bug 395213)
  60. epatch "${FILESDIR}/audacious-plugins_ldflags.patch"
  61. econf \
  62. --enable-modplug \
  63. --enable-neon \
  64. $(use_enable adplug) \
  65. $(use_enable aac) \
  66. $(use_enable alsa) \
  67. $(use_enable alsa amidiplug-alsa) \
  68. $(use_enable aqua coreaudio) \
  69. $(use_enable aqua dockalbumart) \
  70. $(use_enable bs2b) \
  71. $(use_enable cdda cdaudio) \
  72. $(use_enable cue) \
  73. $(use_enable ffmpeg ffaudio) \
  74. $(use_enable flac flacng) \
  75. $(use_enable fluidsynth amidiplug-flsyn) \
  76. $(use_enable flac filewriter_flac) \
  77. $(use_enable ipv6) \
  78. $(use_enable jack) \
  79. $(use_enable gnome gnomeshortcuts) \
  80. $(use_enable lame filewriter_mp3) \
  81. $(use_enable libnotify notify) \
  82. $(use_enable libsamplerate resample) \
  83. $(use_enable mms) \
  84. $(use_enable mp3) \
  85. $(use_enable midi amidiplug) \
  86. $(use_enable mtp mtp_up) \
  87. $(use_enable nls) \
  88. $(use_enable oss) \
  89. $(use_enable pulseaudio pulse) \
  90. $(use_enable scrobbler) \
  91. $(use_enable sid) \
  92. $(use_enable sndfile) \
  93. $(use_enable vorbis) \
  94. $(use_enable vorbis filewriter_vorbis) \
  95. $(use_enable wavpack)
  96. }
  97. src_compile() {
  98. emake || die "make failed"
  99. }
  100. src_install() {
  101. emake DESTDIR="${D}" install || die
  102. dodoc AUTHORS
  103. }