audacious-plugins-3.2.4.ebuild 2.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. MY_P="${P/_/-}"
  5. S="${WORKDIR}/${MY_P}"
  6. DESCRIPTION="Audacious Player - Your music, your way, no exceptions"
  7. HOMEPAGE="http://audacious-media-player.org/"
  8. SRC_URI="http://distfiles.audacious-media-player.org/${MY_P}.tar.bz2"
  9. LICENSE="GPL-2"
  10. SLOT="0"
  11. KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
  12. IUSE="aac adplug alsa bs2b cdda cue ffmpeg flac fluidsynth gnome ipv6 jack
  13. lame libnotify libsamplerate midi mms mp3 mtp nls oss pulseaudio scrobbler sdl sid sndfile vorbis wavpack"
  14. RDEPEND="app-arch/unzip
  15. >=dev-libs/dbus-glib-0.60
  16. dev-libs/libxml2:2
  17. media-libs/libmodplug
  18. ~media-sound/audacious-3.2.4
  19. >=net-libs/neon-0.26.4
  20. x11-libs/gtk+:2
  21. aac? ( >=media-libs/faad2-2.7 )
  22. adplug? ( >=dev-cpp/libbinio-1.4 )
  23. alsa? ( >=media-libs/alsa-lib-1.0.16 )
  24. bs2b? ( media-libs/libbs2b )
  25. cdda? ( >=media-libs/libcddb-1.2.1
  26. >=dev-libs/libcdio-0.79-r1 )
  27. cue? ( media-libs/libcue )
  28. ffmpeg? ( >=virtual/ffmpeg-0.7.3 )
  29. flac? ( >=media-libs/libvorbis-1.0
  30. >=media-libs/flac-1.2.1-r1 )
  31. fluidsynth? ( media-sound/fluidsynth )
  32. jack? ( >=media-libs/bio2jack-0.4
  33. media-sound/jack-audio-connection-kit )
  34. lame? ( media-sound/lame )
  35. libnotify? ( x11-libs/libnotify )
  36. libsamplerate? ( media-libs/libsamplerate )
  37. mms? ( >=media-libs/libmms-0.3 )
  38. mp3? ( >=media-sound/mpg123-1.12.1 )
  39. mtp? ( media-libs/libmtp )
  40. pulseaudio? ( >=media-sound/pulseaudio-0.9.3 )
  41. scrobbler? ( net-misc/curl )
  42. sdl? ( media-libs/libsdl[sound] )
  43. sid? ( >=media-libs/libsidplay-2.1.1-r2 )
  44. sndfile? ( >=media-libs/libsndfile-1.0.17-r1 )
  45. vorbis? ( >=media-libs/libvorbis-1.2.0
  46. >=media-libs/libogg-1.1.3 )
  47. wavpack? ( >=media-sound/wavpack-4.50.1-r1 )"
  48. DEPEND="${RDEPEND}
  49. nls? ( dev-util/intltool )
  50. virtual/pkgconfig"
  51. DOCS="AUTHORS"
  52. mp3_warning() {
  53. if ! use mp3 ; then
  54. ewarn "MP3 support is optional, you may want to enable the mp3 USE-flag"
  55. fi
  56. }
  57. src_configure() {
  58. mp3_warning
  59. econf \
  60. --enable-modplug \
  61. --enable-neon \
  62. --disable-gtk3 \
  63. $(use_enable adplug) \
  64. $(use_enable aac) \
  65. $(use_enable alsa) \
  66. $(use_enable alsa amidiplug-alsa) \
  67. $(use_enable bs2b) \
  68. $(use_enable cdda cdaudio) \
  69. $(use_enable cue) \
  70. $(use_enable ffmpeg ffaudio) \
  71. $(use_enable flac flacng) \
  72. $(use_enable fluidsynth amidiplug-flsyn) \
  73. $(use_enable flac filewriter_flac) \
  74. $(use_enable ipv6) \
  75. $(use_enable jack) \
  76. $(use_enable gnome gnomeshortcuts) \
  77. $(use_enable lame filewriter_mp3) \
  78. $(use_enable libnotify notify) \
  79. $(use_enable libsamplerate resample) \
  80. $(use_enable mms) \
  81. $(use_enable mp3) \
  82. $(use_enable midi amidiplug) \
  83. $(use_enable mtp mtp_up) \
  84. $(use_enable nls) \
  85. $(use_enable oss) \
  86. $(use_enable pulseaudio pulse) \
  87. $(use_enable scrobbler) \
  88. $(use_enable sdl sdlout) \
  89. $(use_enable sid) \
  90. $(use_enable sndfile) \
  91. $(use_enable vorbis) \
  92. $(use_enable wavpack)
  93. }