audacious-plugins-3.4.1.ebuild 3.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils
  5. MY_P="${P/_/-}"
  6. S="${WORKDIR}/${MY_P}"
  7. DESCRIPTION="Audacious Player - Your music, your way, no exceptions"
  8. HOMEPAGE="http://audacious-media-player.org/"
  9. SRC_URI="http://distfiles.audacious-media-player.org/${MY_P}.tar.bz2"
  10. LICENSE="GPL-2"
  11. SLOT="0"
  12. KEYWORDS="alpha amd64 ~arm hppa ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux"
  13. IUSE="aac adplug alsa bs2b cdda cue ffmpeg flac fluidsynth gnome ipv6 jack
  14. lame libnotify libsamplerate lirc midi mms mp3 nls pulseaudio scrobbler sdl sid sndfile vorbis wavpack"
  15. RDEPEND="app-arch/unzip
  16. >=dev-libs/dbus-glib-0.60
  17. dev-libs/libxml2:2
  18. media-libs/libmodplug
  19. ~media-sound/audacious-3.4.1
  20. >=net-libs/neon-0.26.4
  21. x11-libs/gtk+:3
  22. ( || ( >=dev-libs/glib-2.32.2 dev-util/gdbus-codegen ) )
  23. aac? ( >=media-libs/faad2-2.7 )
  24. adplug? ( >=dev-cpp/libbinio-1.4 )
  25. alsa? ( >=media-libs/alsa-lib-1.0.16 )
  26. bs2b? ( media-libs/libbs2b )
  27. cdda? ( >=media-libs/libcddb-1.2.1
  28. dev-libs/libcdio-paranoia )
  29. cue? ( media-libs/libcue )
  30. ffmpeg? ( >=virtual/ffmpeg-0.7.3 )
  31. flac? ( >=media-libs/libvorbis-1.0
  32. >=media-libs/flac-1.2.1-r1 )
  33. fluidsynth? ( media-sound/fluidsynth )
  34. jack? ( >=media-libs/bio2jack-0.4
  35. media-sound/jack-audio-connection-kit )
  36. lame? ( media-sound/lame )
  37. libnotify? ( x11-libs/libnotify )
  38. libsamplerate? ( media-libs/libsamplerate )
  39. lirc? ( app-misc/lirc )
  40. mms? ( >=media-libs/libmms-0.3 )
  41. mp3? ( >=media-sound/mpg123-1.12.1 )
  42. pulseaudio? ( >=media-sound/pulseaudio-0.9.3 )
  43. scrobbler? ( net-misc/curl )
  44. sdl? ( media-libs/libsdl[sound] )
  45. sid? ( >=media-libs/libsidplayfp-1.0.0 )
  46. sndfile? ( >=media-libs/libsndfile-1.0.17-r1 )
  47. vorbis? ( >=media-libs/libvorbis-1.2.0
  48. >=media-libs/libogg-1.1.3 )
  49. wavpack? ( >=media-sound/wavpack-4.50.1-r1 )"
  50. DEPEND="${RDEPEND}
  51. nls? ( dev-util/intltool )
  52. virtual/pkgconfig"
  53. DOCS="AUTHORS"
  54. mp3_warning() {
  55. if ! use mp3 ; then
  56. ewarn "MP3 support is optional, you may want to enable the mp3 USE-flag"
  57. fi
  58. }
  59. src_prepare() {
  60. has_version "<dev-libs/glib-2.32" && \
  61. cd "${S}"/src/mpris2 && \
  62. gdbus-codegen --interface-prefix org.mpris. \
  63. --c-namespace Mpris --generate-c-code object-core mpris2.xml && \
  64. gdbus-codegen --interface-prefix org.mpris. \
  65. --c-namespace Mpris \
  66. --generate-c-code object-player mpris2-player.xml && \
  67. cd "${S}"
  68. }
  69. src_configure() {
  70. mp3_warning
  71. econf \
  72. --enable-modplug \
  73. --disable-soxr \
  74. --enable-neon \
  75. $(use_enable adplug) \
  76. $(use_enable aac) \
  77. $(use_enable alsa) \
  78. $(use_enable alsa amidiplug-alsa) \
  79. $(use_enable bs2b) \
  80. $(use_enable cdda cdaudio) \
  81. $(use_enable cue) \
  82. $(use_enable ffmpeg ffaudio) \
  83. $(use_enable flac flacng) \
  84. $(use_enable fluidsynth amidiplug-flsyn) \
  85. $(use_enable flac filewriter_flac) \
  86. $(use_enable ipv6) \
  87. $(use_enable jack) \
  88. $(use_enable gnome gnomeshortcuts) \
  89. $(use_enable lame filewriter_mp3) \
  90. $(use_enable libnotify notify) \
  91. $(use_enable libsamplerate resample) \
  92. $(use_enable lirc) \
  93. $(use_enable mms) \
  94. $(use_enable mp3) \
  95. $(use_enable midi amidiplug) \
  96. $(use_enable nls) \
  97. $(use_enable pulseaudio pulse) \
  98. $(use_enable scrobbler) \
  99. $(use_enable sdl sdlout) \
  100. $(use_enable sid) \
  101. $(use_enable sndfile) \
  102. $(use_enable vorbis) \
  103. $(use_enable wavpack)
  104. }