audacious-plugins-3.6.2-r1.ebuild 3.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils
  5. MY_P="${P/_/-}"
  6. S="${WORKDIR}/${MY_P}"
  7. DESCRIPTION="Audacious Player - Your music, your way, no exceptions"
  8. HOMEPAGE="http://audacious-media-player.org/"
  9. SRC_URI="!gtk3? ( http://distfiles.audacious-media-player.org/${MY_P}.tar.bz2 )
  10. gtk3? ( http://distfiles.audacious-media-player.org/${MY_P}-gtk3.tar.bz2 )"
  11. LICENSE="GPL-2"
  12. SLOT="0"
  13. KEYWORDS="alpha amd64 ~arm ~hppa ppc ppc64 x86 ~x86-fbsd ~amd64-linux ~x86-linux"
  14. IUSE="aac adplug alsa bs2b cdda cue ffmpeg flac fluidsynth gnome http gtk3 jack
  15. lame libnotify libsamplerate lirc mms mp3 nls pulseaudio qt5 scrobbler sdl sid sndfile vorbis wavpack"
  16. REQUIRED_USE="|| ( alsa flac lame jack pulseaudio qt5 sdl )"
  17. RDEPEND="app-arch/unzip
  18. >=dev-libs/dbus-glib-0.60
  19. dev-libs/libxml2:2
  20. media-libs/libmodplug
  21. ~media-sound/audacious-${PV}
  22. ( || ( >=dev-libs/glib-2.32.2[utils] dev-util/gdbus-codegen ) )
  23. aac? ( >=media-libs/faad2-2.7 )
  24. adplug? ( >=dev-cpp/libbinio-1.4 )
  25. alsa? ( >=media-libs/alsa-lib-1.0.16 )
  26. bs2b? ( media-libs/libbs2b )
  27. cdda? ( >=media-libs/libcddb-1.2.1
  28. dev-libs/libcdio-paranoia )
  29. cue? ( media-libs/libcue )
  30. ffmpeg? ( >=virtual/ffmpeg-0.7.3 )
  31. flac? ( >=media-libs/libvorbis-1.0
  32. >=media-libs/flac-1.2.1-r1 )
  33. fluidsynth? ( media-sound/fluidsynth )
  34. http? ( >=net-libs/neon-0.26.4 )
  35. !gtk3? ( x11-libs/gtk+:2 )
  36. gtk3? ( x11-libs/gtk+:3 )
  37. qt5? ( dev-qt/qtcore:5
  38. dev-qt/qtgui:5
  39. dev-qt/qtmultimedia:5
  40. dev-qt/qtwidgets:5 )
  41. jack? ( >=media-libs/bio2jack-0.4
  42. media-sound/jack-audio-connection-kit )
  43. lame? ( media-sound/lame )
  44. libnotify? ( x11-libs/libnotify )
  45. libsamplerate? ( media-libs/libsamplerate )
  46. lirc? ( app-misc/lirc )
  47. mms? ( >=media-libs/libmms-0.3 )
  48. mp3? ( >=media-sound/mpg123-1.12.1 )
  49. pulseaudio? ( >=media-sound/pulseaudio-0.9.3 )
  50. scrobbler? ( net-misc/curl )
  51. sdl? ( media-libs/libsdl[sound] )
  52. sid? ( >=media-libs/libsidplayfp-1.0.0 )
  53. sndfile? ( >=media-libs/libsndfile-1.0.17-r1 )
  54. vorbis? ( >=media-libs/libvorbis-1.2.0
  55. >=media-libs/libogg-1.1.3 )
  56. wavpack? ( >=media-sound/wavpack-4.50.1-r1 )"
  57. DEPEND="${RDEPEND}
  58. nls? ( dev-util/intltool )
  59. virtual/pkgconfig"
  60. mp3_warning() {
  61. if ! use mp3 ; then
  62. ewarn "MP3 support is optional, you may want to enable the mp3 USE-flag"
  63. fi
  64. }
  65. src_unpack() {
  66. default
  67. if use gtk3 ; then
  68. mv "${MY_P}-gtk3" "${MY_P}"
  69. fi
  70. }
  71. src_prepare() {
  72. has_version "<dev-libs/glib-2.32" && \
  73. cd "${S}"/src/mpris2 && \
  74. gdbus-codegen --interface-prefix org.mpris. \
  75. --c-namespace Mpris --generate-c-code object-core mpris2.xml && \
  76. gdbus-codegen --interface-prefix org.mpris. \
  77. --c-namespace Mpris \
  78. --generate-c-code object-player mpris2-player.xml && \
  79. cd "${S}"
  80. }
  81. src_configure() {
  82. mp3_warning
  83. if use ffmpeg && has_version media-video/ffmpeg ; then
  84. ffmpeg="--with-ffmpeg=ffmpeg"
  85. elif use ffmpeg && has_version media-video/libav ; then
  86. ffmpeg="--with-ffmpeg=libav"
  87. else
  88. ffmpeg="--with-ffmpeg=none"
  89. fi
  90. econf \
  91. ${ffmpeg} \
  92. --enable-modplug \
  93. --enable-statusicon \
  94. --disable-soxr \
  95. $(use_enable adplug) \
  96. $(use_enable aac) \
  97. $(use_enable alsa) \
  98. $(use_enable bs2b) \
  99. $(use_enable cdda cdaudio) \
  100. $(use_enable cue) \
  101. $(use_enable flac flacng) \
  102. $(use_enable fluidsynth amidiplug) \
  103. $(use_enable flac filewriter_flac) \
  104. $(use_enable http neon) \
  105. $(use_enable jack) \
  106. $(use_enable gnome gnomeshortcuts) \
  107. $(use_enable lame filewriter_mp3) \
  108. $(use_enable libnotify notify) \
  109. $(use_enable libsamplerate resample) \
  110. $(use_enable lirc) \
  111. $(use_enable mms) \
  112. $(use_enable mp3) \
  113. $(use_enable nls) \
  114. $(use_enable pulseaudio pulse) \
  115. $(use_enable qt5 qt) \
  116. $(use_enable scrobbler scrobbler2) \
  117. $(use_enable sdl sdlout) \
  118. $(use_enable sid) \
  119. $(use_enable sndfile) \
  120. $(use_enable vorbis) \
  121. $(use_enable wavpack)
  122. }