audacious-plugins-3.7.1-r1.ebuild 4.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils
  5. MY_P="${P/_/-}"
  6. S="${WORKDIR}/${MY_P}"
  7. DESCRIPTION="Audacious Player - Your music, your way, no exceptions"
  8. HOMEPAGE="http://audacious-media-player.org/"
  9. SRC_URI="!gtk3? ( http://distfiles.audacious-media-player.org/${MY_P}.tar.bz2 )
  10. gtk3? ( http://distfiles.audacious-media-player.org/${MY_P}-gtk3.tar.bz2 )"
  11. LICENSE="GPL-2"
  12. SLOT="0"
  13. KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
  14. IUSE="aac +adplug alsa bs2b cdda cue ffmpeg flac fluidsynth gnome http gtk gtk3 jack
  15. lame libnotify libsamplerate lirc mms mp3 nls pulseaudio qt5 scrobbler sdl sid sndfile vorbis wavpack"
  16. REQUIRED_USE="
  17. ^^ ( gtk gtk3 qt5 )
  18. "
  19. # The following plugins REQUIRE a GUI build of audacious, because non-GUI
  20. # builds do NOT install the libaudgui library & headers.
  21. # Plugins without a configure option:
  22. # alarm
  23. # albumart
  24. # delete-files
  25. # ladspa
  26. # playlist-manager
  27. # search-tool
  28. # skins
  29. # vtx
  30. # Plugins with a configure option:
  31. # glspectrum
  32. # gtkui
  33. # hotkey
  34. # notify
  35. # statusicon
  36. RDEPEND="app-arch/unzip
  37. >=dev-libs/dbus-glib-0.60
  38. dev-libs/libxml2:2
  39. media-libs/libmodplug
  40. ~media-sound/audacious-${PV}
  41. >=media-sound/audacious-3.7.1-r1
  42. ( || ( >=dev-libs/glib-2.32.2[utils] dev-util/gdbus-codegen ) )
  43. aac? ( >=media-libs/faad2-2.7 )
  44. adplug? ( media-libs/adplug )
  45. alsa? ( >=media-libs/alsa-lib-1.0.16 )
  46. bs2b? ( media-libs/libbs2b )
  47. cdda? ( >=media-libs/libcddb-1.2.1
  48. dev-libs/libcdio-paranoia )
  49. cue? ( media-libs/libcue )
  50. ffmpeg? ( >=virtual/ffmpeg-0.7.3 )
  51. flac? ( >=media-libs/libvorbis-1.0
  52. >=media-libs/flac-1.2.1-r1 )
  53. fluidsynth? ( media-sound/fluidsynth )
  54. http? ( >=net-libs/neon-0.26.4 )
  55. gtk? ( x11-libs/gtk+:2
  56. ~media-sound/audacious-${PV}[gtk?] )
  57. gtk3? ( x11-libs/gtk+:3
  58. media-libs/adplug
  59. ~media-sound/audacious-${PV}[gtk3?] )
  60. qt5? ( dev-qt/qtcore:5
  61. dev-qt/qtgui:5
  62. dev-qt/qtmultimedia:5
  63. dev-qt/qtwidgets:5
  64. media-libs/adplug
  65. ~media-sound/audacious-${PV}[qt5?] )
  66. jack? ( >=media-libs/bio2jack-0.4
  67. media-sound/jack-audio-connection-kit )
  68. lame? ( media-sound/lame )
  69. libnotify? ( x11-libs/libnotify )
  70. libsamplerate? ( media-libs/libsamplerate )
  71. lirc? ( app-misc/lirc )
  72. mms? ( >=media-libs/libmms-0.3 )
  73. mp3? ( >=media-sound/mpg123-1.12.1 )
  74. pulseaudio? ( >=media-sound/pulseaudio-0.9.3 )
  75. scrobbler? ( net-misc/curl )
  76. sdl? ( media-libs/libsdl[sound] )
  77. sid? ( >=media-libs/libsidplayfp-1.0.0 )
  78. sndfile? ( >=media-libs/libsndfile-1.0.17-r1 )
  79. vorbis? ( >=media-libs/libvorbis-1.2.0
  80. >=media-libs/libogg-1.1.3 )
  81. wavpack? ( >=media-sound/wavpack-4.50.1-r1 )"
  82. DEPEND="${RDEPEND}
  83. nls? ( dev-util/intltool )
  84. virtual/pkgconfig"
  85. mp3_warning() {
  86. if ! use mp3 ; then
  87. ewarn "MP3 support is optional, you may want to enable the mp3 USE-flag"
  88. fi
  89. }
  90. src_unpack() {
  91. default
  92. if use gtk3 ; then
  93. mv "${MY_P}-gtk3" "${MY_P}"
  94. fi
  95. }
  96. src_prepare() {
  97. has_version "<dev-libs/glib-2.32" && \
  98. cd "${S}"/src/mpris2 && \
  99. gdbus-codegen --interface-prefix org.mpris. \
  100. --c-namespace Mpris --generate-c-code object-core mpris2.xml && \
  101. gdbus-codegen --interface-prefix org.mpris. \
  102. --c-namespace Mpris \
  103. --generate-c-code object-player mpris2-player.xml && \
  104. cd "${S}"
  105. }
  106. src_configure() {
  107. mp3_warning
  108. if use qt5 ;then
  109. notify="--disable-notify"
  110. elif use libnotify ;then
  111. notify="--enable-notify"
  112. fi
  113. if use gtk ;then
  114. gtk="--enable-gtk"
  115. elif use gtk3 ;then
  116. gtk="--enable-gtk"
  117. else
  118. gtk="--disable-gtk"
  119. fi
  120. if use ffmpeg && has_version media-video/ffmpeg ; then
  121. ffmpeg="--with-ffmpeg=ffmpeg"
  122. elif use ffmpeg && has_version media-video/libav ; then
  123. ffmpeg="--with-ffmpeg=libav"
  124. else
  125. ffmpeg="--with-ffmpeg=none"
  126. fi
  127. econf \
  128. ${ffmpeg} \
  129. ${gtk} \
  130. ${notify} \
  131. --enable-modplug \
  132. --enable-statusicon \
  133. --disable-soxr \
  134. $(use_enable adplug) \
  135. $(use_enable aac) \
  136. $(use_enable alsa) \
  137. $(use_enable bs2b) \
  138. $(use_enable cdda cdaudio) \
  139. $(use_enable cue) \
  140. $(use_enable flac flacng) \
  141. $(use_enable fluidsynth amidiplug) \
  142. $(use_enable flac filewriter_flac) \
  143. $(use_enable http neon) \
  144. $(use_enable jack) \
  145. $(use_enable gnome gnomeshortcuts) \
  146. $(use_enable lame filewriter_mp3) \
  147. $(use_enable libsamplerate resample) \
  148. $(use_enable lirc) \
  149. $(use_enable mms) \
  150. $(use_enable mp3) \
  151. $(use_enable nls) \
  152. $(use_enable pulseaudio pulse) \
  153. $(use_enable qt5 qt) \
  154. $(use_enable scrobbler scrobbler2) \
  155. $(use_enable sdl sdlout) \
  156. $(use_enable sid) \
  157. $(use_enable sndfile) \
  158. $(use_enable vorbis) \
  159. $(use_enable wavpack)
  160. }