gmpc-jamendo-11.8.16.ebuild 676 B

1234567891011121314151617181920212223242526272829303132
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. DESCRIPTION="Plugin allows you to browse and preview music available on jamendo"
  5. HOMEPAGE="http://gmpc.wikia.com/wiki/GMPC_PLUGIN_JAMENDO"
  6. SRC_URI="http://download.sarine.nl/Programs/gmpc/11.8/${P}.tar.gz"
  7. LICENSE="GPL-2"
  8. SLOT="0"
  9. KEYWORDS="amd64 x86"
  10. IUSE="nls"
  11. RDEPEND=">=media-sound/gmpc-${PV}
  12. dev-db/sqlite:3
  13. dev-libs/libxml2:2"
  14. DEPEND="${RDEPEND}
  15. virtual/pkgconfig
  16. dev-util/gob
  17. nls? ( dev-util/intltool
  18. sys-devel/gettext )"
  19. src_configure() {
  20. econf $(use_enable nls)
  21. }
  22. src_install() {
  23. default
  24. find "${ED}" -name "*.la" -exec rm {} + || die
  25. }