12345678910111213141516171819202122232425262728293031323334 |
- # Copyright 1999-2012 Gentoo Foundation
- # Distributed under the terms of the GNU General Public License v2
- EAPI=3
- DESCRIPTION="This plugin calls ogg123 and points it at mpd's shoutstream"
- HOMEPAGE="http://gmpc.wikia.com/wiki/GMPC_PLUGIN_SHOUT"
- SRC_URI="mirror://sourceforge/musicpd/${P}.tar.gz"
- LICENSE="GPL-2"
- SLOT="0"
- KEYWORDS="amd64 x86"
- IUSE="nls"
- RDEPEND=">=media-sound/gmpc-${PV}
- media-sound/vorbis-tools[ogg123]
- dev-libs/libxml2
- x11-libs/cairo"
- DEPEND="${RDEPEND}
- virtual/pkgconfig
- nls? ( dev-util/intltool
- sys-devel/gettext )"
- src_configure() {
- econf \
- --disable-dependency-tracking \
- $(use_enable nls)
- }
- src_install() {
- emake DESTDIR="${D}" install || die
- find "${ED}" -name "*.la" -delete || die
- }
|