gst-plugins-libav-1.10.4.ebuild 2.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit eutils multilib-minimal
  5. MY_PN="gst-libav"
  6. DESCRIPTION="FFmpeg based gstreamer plugin"
  7. HOMEPAGE="https://gstreamer.freedesktop.org/modules/gst-libav.html"
  8. SRC_URI="https://gstreamer.freedesktop.org/src/${MY_PN}/${MY_PN}-${PV}.tar.xz"
  9. LICENSE="GPL-2"
  10. SLOT="1.0"
  11. KEYWORDS="alpha amd64 arm hppa ~mips ppc ppc64 x86 ~amd64-fbsd ~x86-fbsd"
  12. IUSE="libav +orc"
  13. # XXX: bzip2/lzma are automagic
  14. # Move back to ${PV} deps of gstreamer/gst-plugins-base later; 1.10.4 had it reduced for lone security stabilization
  15. RDEPEND="
  16. app-arch/bzip2
  17. app-arch/xz-utils
  18. >=dev-libs/glib-2.40.0:2[${MULTILIB_USEDEP}]
  19. >=media-libs/gstreamer-1.10.3:1.0[${MULTILIB_USEDEP}]
  20. >=media-libs/gst-plugins-base-1.10.3:1.0[${MULTILIB_USEDEP}]
  21. !libav? ( >=media-video/ffmpeg-3.2.4:0=[${MULTILIB_USEDEP}] )
  22. orc? ( >=dev-lang/orc-0.4.17[${MULTILIB_USEDEP}] )
  23. "
  24. DEPEND="${RDEPEND}
  25. >=dev-util/gtk-doc-am-1.12
  26. >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
  27. "
  28. S="${WORKDIR}/${MY_PN}-${PV}"
  29. RESTRICT="test" # FIXME: tests seem to get stuck at one point; investigate properly
  30. multilib_src_configure() {
  31. GST_PLUGINS_BUILD=""
  32. # Upstream dropped support for system libav and won't work
  33. # for preserving its compat anymore, forcing us to rely on internal
  34. # ffmpeg copy if we don't want to cause unresolvable blockers for
  35. # libav setups.
  36. # https://bugzilla.gnome.org/show_bug.cgi?id=758183
  37. # Prefer system ffmpeg for -libav
  38. local myconf
  39. if use libav; then
  40. ewarn "Using internal ffmpeg copy as upstream dropped"
  41. ewarn "the support for compiling against system libav"
  42. ewarn "http://bugzilla.gnome.org/show_bug.cgi?id=758183"
  43. else
  44. myconf="--with-system-libav"
  45. fi
  46. ECONF_SOURCE=${S} \
  47. econf \
  48. --disable-maintainer-mode \
  49. --with-package-name="Gentoo GStreamer ebuild" \
  50. --with-package-origin="https://www.gentoo.org" \
  51. --disable-fatal-warnings \
  52. $(use_enable orc) \
  53. ${myconf}
  54. }
  55. multilib_src_compile() {
  56. # Don't build with -Werror
  57. emake ERROR_CFLAGS=
  58. }
  59. multilib_src_install_all() {
  60. einstalldocs
  61. prune_libtool_files --modules
  62. }