kodi-audiodecoder-modplug-9999.ebuild 697 B

1234567891011121314151617181920212223242526272829303132333435363738
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit cmake-utils kodi-addon
  5. DESCRIPTION="Modplug decoder addon for Kodi"
  6. HOMEPAGE="https://github.com/notspiff/audiodecoder.modplug"
  7. SRC_URI=""
  8. case ${PV} in
  9. 9999)
  10. SRC_URI=""
  11. EGIT_REPO_URI="git://github.com/notspiff/audiodecoder.modplug.git"
  12. inherit git-r3
  13. ;;
  14. *)
  15. KEYWORDS="~amd64 ~x86"
  16. SRC_URI="https://github.com/notspiff/audiodecoder.modplug/archive/v${PV}.tar.gz -> ${P}.tar.gz"
  17. S="${WORKDIR}/audiodecoder.modplug-${PV}"
  18. ;;
  19. esac
  20. LICENSE="GPL-2"
  21. SLOT="0"
  22. IUSE=""
  23. DEPEND="
  24. media-tv/kodi
  25. media-libs/kodi-platform
  26. media-libs/libmodplug
  27. "
  28. RDEPEND="
  29. ${DEPEND}
  30. "