kodi-peripheral-joystick-9999.ebuild 733 B

1234567891011121314151617181920212223242526272829303132333435363738
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit cmake-utils kodi-addon
  5. DESCRIPTION="Libretro compatibility layer for the Kodi Game API"
  6. HOMEPAGE="https://github.com/xbmc/peripheral.joystick"
  7. SRC_URI=""
  8. case ${PV} in
  9. 9999)
  10. SRC_URI=""
  11. EGIT_REPO_URI="git://github.com/xbmc/peripheral.joystick.git"
  12. inherit git-r3
  13. ;;
  14. *)
  15. KEYWORDS="~amd64 ~x86"
  16. SRC_URI="https://github.com/xbmc/peripheral.joystick/archive/v${PV}.tar.gz -> ${P}.tar.gz"
  17. S="${WORKDIR}/peripheral.joystick-${PV}"
  18. ;;
  19. esac
  20. LICENSE="GPL-2"
  21. SLOT="0"
  22. IUSE=""
  23. DEPEND="
  24. =media-tv/kodi-9999
  25. =media-libs/kodi-platform-9999
  26. =dev-libs/libplatform-2*
  27. dev-libs/libpcre
  28. "
  29. RDEPEND="
  30. ${DEPEND}
  31. "