mediastreamer-x264-1.4.1.ebuild 676 B

1234567891011121314151617181920212223242526272829303132333435
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="4"
  4. inherit multilib
  5. MY_P="msx264-${PV}"
  6. DESCRIPTION="mediastreamer plugin: add H264 support"
  7. HOMEPAGE="http://www.linphone.org/"
  8. SRC_URI="mirror://nongnu/linphone/plugins/sources/${MY_P}.tar.gz"
  9. LICENSE="GPL-2"
  10. SLOT="0"
  11. KEYWORDS="amd64 ppc ppc64 x86"
  12. IUSE=""
  13. RDEPEND=">=media-libs/mediastreamer-2.7.0[video]
  14. >=media-libs/x264-0.0.20100118
  15. virtual/ffmpeg"
  16. DEPEND="${RDEPEND}
  17. virtual/pkgconfig"
  18. DOCS="AUTHORS NEWS README"
  19. S=${WORKDIR}/${MY_P}
  20. src_configure() {
  21. # strict: don't want -Werror
  22. econf \
  23. --libdir=/usr/$(get_libdir) \
  24. --disable-strict
  25. }