mediastreamer-x264-1.4.2.ebuild 604 B

123456789101112131415161718192021222324252627282930
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. MY_P="msx264-${PV}"
  5. DESCRIPTION="mediastreamer plugin: add H264 support"
  6. HOMEPAGE="http://www.linphone.org/"
  7. SRC_URI="mirror://nongnu/linphone/plugins/sources/${MY_P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
  11. IUSE=""
  12. RDEPEND=">=media-libs/mediastreamer-2.7.0:=[video]
  13. >=media-libs/x264-0.0.20100118:=
  14. virtual/ffmpeg"
  15. DEPEND="${RDEPEND}
  16. virtual/pkgconfig"
  17. S=${WORKDIR}/${MY_P}
  18. src_configure() {
  19. # strict: don't want -Werror
  20. econf \
  21. --disable-strict
  22. }