vdr-joystick-0.0.3.ebuild 822 B

123456789101112131415161718192021222324252627282930313233343536
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit vdr-plugin-2
  5. DESCRIPTION="VDR plugin: allows using a joystick as a remote control for VDR"
  6. HOMEPAGE="http://www.powarman.de/vdr_plugins.htm"
  7. SRC_URI="http://home.arcor.de/andreas.regel/files/joystick/${P}.tgz"
  8. SLOT="0"
  9. LICENSE="GPL-2"
  10. KEYWORDS="~x86 ~amd64"
  11. IUSE=""
  12. DEPEND=">=media-video/vdr-1.4.6"
  13. RDEPEND="${DEPEND}"
  14. src_install() {
  15. vdr-plugin-2_src_install
  16. insinto /etc/vdr/plugins/joystick
  17. doins "${FILESDIR}"/mapping.conf
  18. }
  19. pkg_postinst() {
  20. vdr-plugin-2_pkg_postinst
  21. echo
  22. elog "To use the plugin your joystick has to be connected to your game port and its kernel module has to be loaded."
  23. elog "Check configuration file:"
  24. elog "/etc/vdr/plugins/joystick/mapping.conf"
  25. echo
  26. }