vdr-mount-0.0.2.ebuild 648 B

1234567891011121314151617181920212223242526272829
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit vdr-plugin-2
  5. DESCRIPTION="VDR plugin: (Un)Mount removable media via osd"
  6. HOMEPAGE="http://www.vdr-wiki.de/wiki/index.php/Mount-plugin"
  7. SRC_URI="http://homepages.physik.uni-muenchen.de/~Felix.Rauscher/${P}.tgz"
  8. KEYWORDS="~x86 ~amd64"
  9. SLOT="0"
  10. LICENSE="GPL-2"
  11. IUSE=""
  12. DEPEND=">=media-video/vdr-1.2.6"
  13. PATCHES=("${FILESDIR}/${P}-makefile-fix.diff")
  14. src_prepare() {
  15. vdr-plugin-2_src_prepare
  16. if has_version ">=media-video/vdr-2.1.2"; then
  17. sed -e "s#VideoDirectory#cVideoDirectory::Name\(\)#" \
  18. -i MediumItem.C
  19. fi
  20. }