gpredict-1.3.ebuild 1.0 KB

1234567891011121314151617181920212223242526272829303132333435363738394041
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit autotools eutils
  5. DESCRIPTION="Real-time satellite tracking and orbit prediction application"
  6. HOMEPAGE="http://gpredict.oz9aec.net"
  7. SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 ppc x86"
  11. IUSE=""
  12. RDEPEND=">=dev-libs/glib-2.22.0:2
  13. >=x11-libs/gtk+-2.18.0:2
  14. >=x11-libs/goocanvas-0.14:0
  15. net-misc/curl"
  16. DEPEND="${RDEPEND}
  17. dev-util/intltool
  18. virtual/pkgconfig
  19. sys-devel/gettext"
  20. src_prepare() {
  21. # remove wrong doc location
  22. epatch "${FILESDIR}/${PN}-1.1-doc.patch"
  23. sed -i -e "s/0.15/0.14/g" configure.ac || die
  24. eautoreconf
  25. }
  26. src_install() {
  27. emake DESTDIR="${D}" install
  28. make_desktop_entry ${PN} "GPredict" "/usr/share/pixmaps/gpredict/icons/gpredict-icon.png" Science
  29. # provide a link to GPL license to allow the program to show it (see
  30. # Help->license menu entry)
  31. dosym /usr/portage/licenses/GPL-2 /usr/share/${PN}/COPYING
  32. dodoc AUTHORS ChangeLog NEWS README TODO
  33. }