grig-0.8.1.ebuild 651 B

1234567891011121314151617181920212223242526272829303132
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils
  5. DESCRIPTION="A tool for controlling amateur radios"
  6. HOMEPAGE="http://groundstation.sourceforge.net/grig/"
  7. SRC_URI="mirror://sourceforge/groundstation/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 x86"
  11. IUSE=""
  12. DEPEND="
  13. dev-libs/glib:2
  14. x11-libs/gtk+:2
  15. media-libs/hamlib"
  16. RDEPEND="${DEPEND}"
  17. src_configure() {
  18. econf --enable-hardware
  19. }
  20. src_install() {
  21. default
  22. make_desktop_entry ${PN} "GRig" "/usr/share/pixmaps/grig/grig-logo.png" "HamRadio"
  23. rm -rf "${D}/usr/share/grig" || die "cleanup docs failed"
  24. }