qrq-0.3.1.ebuild 892 B

12345678910111213141516171819202122232425262728293031323334353637383940
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. inherit toolchain-funcs
  5. DESCRIPTION="Yet another CW trainer for Linux/Unix"
  6. HOMEPAGE="http://fkurz.net/ham/qrq.html"
  7. SRC_URI="http://fkurz.net/ham/${PN}/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 x86"
  11. IUSE="pulseaudio"
  12. DEPEND="sys-libs/ncurses:*
  13. pulseaudio? ( media-sound/pulseaudio )"
  14. RDEPEND="${DEPEND}"
  15. src_prepare() {
  16. # avoid prestripping of 'qrq' binary
  17. sed -i -e "s/install -s -m/install -m/" Makefile || die
  18. sed -i -e "s/CC=gcc/CC=$(tc-getCC)/" Makefile || die
  19. sed -i -e "s/-lpulse-simple/-lpthread -lpulse-simple/" Makefile || die
  20. }
  21. src_compile() {
  22. CONF="USE_PA=NO USE_OSS=YES"
  23. if use pulseaudio; then
  24. CONF="USE_PA=YES USE_OSS=NO"
  25. fi
  26. emake $CONF
  27. }
  28. src_install() {
  29. emake $CONF DESTDIR="${D}/usr" install
  30. dodoc AUTHORS ChangeLog README
  31. }