xastir-2.0.6-r1.ebuild 2.2 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879808182838485
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit autotools eutils flag-o-matic toolchain-funcs
  5. DESCRIPTION="X Amateur Station Tracking and Information Reporting"
  6. HOMEPAGE="http://xastir.sourceforge.net/"
  7. SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 x86"
  11. IUSE="festival gdal geotiff graphicsmagick"
  12. DEPEND=">=x11-libs/motif-2.3:0
  13. x11-libs/libXt
  14. x11-libs/libX11
  15. x11-libs/libXpm
  16. x11-apps/xfontsel
  17. dev-libs/libpcre
  18. net-misc/curl
  19. sys-libs/db:4.8
  20. sci-libs/shapelib
  21. !graphicsmagick? ( media-gfx/imagemagick:=[-hdri,-q32] )
  22. graphicsmagick? ( media-gfx/graphicsmagick:=[-q32] )
  23. geotiff? ( sci-libs/proj
  24. sci-libs/libgeotiff
  25. media-libs/tiff:0 )
  26. gdal? ( sci-libs/gdal )
  27. festival? ( app-accessibility/festival )"
  28. RDEPEND="${DEPEND}"
  29. src_prepare() {
  30. # fix script location (bug #407185)
  31. epatch "${FILESDIR}"/${PN}-2.0.4-scripts.diff
  32. # fix __FORTIFY_SOURCE warning (bug #337365)
  33. epatch "${FILESDIR}"/${PN}-2.0.4-fortify.diff
  34. # do not use builtin shapelib if sci-libs/shapelib is not installed
  35. # instead build without shapelib support (bug #430704)
  36. epatch "${FILESDIR}"/${PN}-2.0.4-no-builtin-shapelib.diff
  37. # do not filter duplicate flags (see bug 411095)
  38. epatch "${FILESDIR}"/${PN}-2.0.0-dont-filter-flags.diff
  39. eautoreconf
  40. }
  41. src_configure() {
  42. # provide include path to GraphicsMagic for configure stage
  43. use graphicsmagick && append-cflags -I/usr/include/GraphicsMagick
  44. econf --with-pcre \
  45. --with-shapelib \
  46. --with-dbfawk \
  47. --without-ax25 \
  48. --without-gpsman \
  49. $(use_with !graphicsmagick imagemagick) \
  50. $(use_with graphicsmagick) \
  51. $(use_with geotiff libproj) \
  52. $(use_with geotiff) \
  53. $(use_with gdal) \
  54. $(use_with festival)
  55. }
  56. src_compile() {
  57. emake AR="$(tc-getAR)"
  58. }
  59. src_install() {
  60. emake DESTDIR="${D}" install
  61. rm -rf "${D}"/usr/share/doc/${PN}
  62. dodoc AUTHORS ChangeLog FAQ README README.Contributing \
  63. README.Getting-Started README.MAPS
  64. }
  65. pkg_postinst() {
  66. elog "Kernel mode AX.25 and GPSman library not supported."
  67. elog
  68. elog "Remember you have to be root to add addditional scripts,"
  69. elog "maps and other configuration data under /usr/share/xastir."
  70. }