ivtvplayer-0.1.3-r1.ebuild 908 B

1234567891011121314151617181920212223242526272829303132333435363738394041
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="2"
  4. inherit eutils
  5. DESCRIPTION="Simple IVTV command line TV and radio player with support of LIRC"
  6. HOMEPAGE="https://sourceforge.net/projects/ivtvplayer/"
  7. SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
  8. SLOT="0"
  9. LICENSE="GPL-2"
  10. KEYWORDS="~amd64 ~x86"
  11. IUSE="gtk xosd"
  12. RDEPEND="media-tv/v4l-utils
  13. || ( media-video/mplayer[v4l]
  14. media-video/mplayer[dvb] )
  15. media-sound/alsa-utils
  16. dev-perl/XML-Simple
  17. gtk? ( dev-perl/Gtk2 )
  18. xosd? ( dev-perl/X-Osd )
  19. >=dev-perl/Lirc-Client-1.50"
  20. DEPEND=""
  21. src_install() {
  22. dobin bin/itv
  23. dobin bin/iradio
  24. if use gtk ; then
  25. dobin bin/ictl
  26. fi
  27. dodoc doc/README doc/CHANGES
  28. dodoc conf/*
  29. }
  30. pkg_postinst() {
  31. einfo ""
  32. einfo "Example of itv, iradio and its LIRC configuration file is located in"
  33. einfo "directory /usr/share/doc/${PF}/."
  34. einfo ""
  35. }