dnscrypt-proxy-1.4.3.ebuild 917 B

12345678910111213141516171819202122232425262728293031323334353637383940414243
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils systemd user
  5. DESCRIPTION="A tool for securing communications between a client and a DNS resolver"
  6. HOMEPAGE="http://dnscrypt.org/"
  7. SRC_URI="http://download.dnscrypt.org/${PN}/${P}.tar.gz"
  8. LICENSE="ISC"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. IUSE="+plugins ldns systemd"
  12. DEPEND="dev-libs/libsodium
  13. ldns? ( net-libs/ldns )"
  14. RDEPEND="${DEPEND}
  15. systemd? ( sys-apps/systemd )"
  16. DOCS=( AUTHORS ChangeLog COPYING NEWS README.markdown README-PLUGINS.markdown
  17. TECHNOTES THANKS )
  18. pkg_setup() {
  19. enewgroup dnscrypt
  20. enewuser dnscrypt -1 -1 /var/empty dnscrypt
  21. }
  22. src_configure() {
  23. econf \
  24. $(use_enable plugins) \
  25. $(use_with systemd )
  26. }
  27. src_install() {
  28. default
  29. newinitd "${FILESDIR}/${PN}.initd" ${PN}
  30. newconfd "${FILESDIR}/${PN}.confd" ${PN}
  31. systemd_dounit "${FILESDIR}"/${PN}.service
  32. }