dnstop-20140915-r2.ebuild 653 B

12345678910111213141516171819202122232425262728293031323334353637
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit autotools
  5. DESCRIPTION="Displays various tables of DNS traffic on your network"
  6. HOMEPAGE="http://dnstop.measurement-factory.com/"
  7. SRC_URI="http://dnstop.measurement-factory.com/src/${P}.tar.gz"
  8. LICENSE="BSD"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~arm ~hppa ~ppc ~x86"
  11. IUSE=""
  12. RDEPEND="sys-libs/ncurses:0
  13. net-libs/libpcap"
  14. DEPEND="${RDEPEND}"
  15. PATCHES=( "${FILESDIR}/${P}"-pkg-config.patch )
  16. src_prepare() {
  17. default
  18. eautoreconf
  19. }
  20. src_configure() {
  21. econf --enable-ipv6
  22. }
  23. src_install() {
  24. dobin dnstop
  25. doman dnstop.8
  26. dodoc CHANGES
  27. }