fpdns-0.10.0_pre20130404-r1.ebuild 685 B

12345678910111213141516171819202122232425262728293031323334
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils perl-module
  5. DESCRIPTION="Fingerprinting DNS servers"
  6. HOMEPAGE="https://github.com/kirei/fpdns/"
  7. MY_P="${PN}-${PV##*_pre}"
  8. SRC_URI="https://github.com/kirei/fpdns/archive/20130404.tar.gz -> ${P}.tar.gz"
  9. LICENSE="BSD"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~x86"
  12. IUSE=""
  13. DEPEND=""
  14. RDEPEND=">=dev-perl/Net-DNS-0.74"
  15. S="${WORKDIR}"/"${MY_P}"
  16. src_prepare() {
  17. ## fixes https://github.com/kirei/fpdns/issues/6
  18. epatch "${FILESDIR}/${P}.ro-header.patch"
  19. }
  20. src_install() {
  21. newbin apps/fpdns fpdns
  22. insinto "${VENDOR_LIB}"/Net/DNS/
  23. doins lib/Net/DNS/Fingerprint.pm
  24. }