s6-dns-2.1.0.0.ebuild 1.1 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit versionator
  5. DESCRIPTION="suite of DNS client programs and libraries for Unix systems"
  6. HOMEPAGE="http://www.skarnet.org/software/s6-dns/"
  7. SRC_URI="http://www.skarnet.org/software/${PN}/${P}.tar.gz"
  8. LICENSE="ISC"
  9. SLOT="0/$(get_version_component_range 1-2)"
  10. KEYWORDS="~amd64 ~x86"
  11. IUSE="static static-libs"
  12. DEPEND=">=sys-devel/make-3.81
  13. static? (
  14. >=dev-libs/skalibs-2.4.0.0[static-libs]
  15. )
  16. !static? (
  17. >=dev-libs/skalibs-2.4.0.0
  18. )
  19. "
  20. RDEPEND="
  21. !static? (
  22. >=dev-libs/skalibs-2.4.0.0:=
  23. )
  24. "
  25. HTML_DOCS="doc/*"
  26. src_prepare() {
  27. default
  28. # Remove QA warning about LDFLAGS addition
  29. sed -i "s/tryldflag LDFLAGS_AUTO -Wl,--hash-style=both/:/" "${S}/configure" || die
  30. }
  31. src_configure() {
  32. econf \
  33. --bindir=/bin \
  34. --dynlibdir=/$(get_libdir) \
  35. --libdir=/usr/$(get_libdir)/${PN} \
  36. --with-dynlib=/$(get_libdir) \
  37. --with-lib=/usr/$(get_libdir)/skalibs \
  38. --with-sysdeps=/usr/$(get_libdir)/skalibs \
  39. $(use_enable !static shared) \
  40. $(use_enable static allstatic) \
  41. $(use_enable static static-libc) \
  42. $(use_enable static-libs static)
  43. }