totd-1.5.1.ebuild 905 B

12345678910111213141516171819202122232425262728293031323334353637383940414243444546
  1. # Copyright 1999-2013 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. inherit eutils
  5. DESCRIPTION="Trick Or Treat Daemon, a DNS proxy for 6to4"
  6. HOMEPAGE="http://www.dillema.net/software/totd.html"
  7. SRC_URI="http://www.dillema.net/software/${PN}/${P}.tar.gz"
  8. LICENSE="totd BSD BSD-4"
  9. SLOT="0"
  10. KEYWORDS="~amd64 x86"
  11. IUSE=""
  12. DEPEND=""
  13. RDEPEND=""
  14. src_prepare() {
  15. epatch "${FILESDIR}"/${P}-no_werror.patch
  16. }
  17. src_configure() {
  18. econf \
  19. --enable-ipv4 \
  20. --enable-ipv6 \
  21. --enable-stf \
  22. --enable-scoped-rewrite \
  23. --disable-http-server
  24. }
  25. src_install() {
  26. dosbin totd
  27. doman totd.8
  28. dodoc totd.conf.sample README INSTALL
  29. doinitd "${FILESDIR}"/totd
  30. }
  31. pkg_postinst() {
  32. elog "The totd.conf.sample file in /usr/share/doc/${P}/ contains"
  33. elog "a sample config file for totd. Make sure you create"
  34. elog "/etc/totd.conf with the necessary configurations"
  35. }