libnfs-1.9.5.ebuild 1.1 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. AUTOTOOLS_AUTORECONF="1"
  5. inherit eutils
  6. if [[ ${PV} == "9999" ]] ; then
  7. EGIT_REPO_URI="git://github.com/sahlberg/libnfs.git"
  8. inherit git-2 autotools-utils
  9. else
  10. SRC_URI="https://github.com/sahlberg/${PN}/archive/${P}.tar.gz"
  11. KEYWORDS="alpha amd64 arm hppa ppc ppc64 x86"
  12. inherit autotools-utils
  13. fi
  14. DESCRIPTION="Client library for accessing NFS shares over a network"
  15. HOMEPAGE="https://github.com/sahlberg/libnfs"
  16. LICENSE="LGPL-2.1 GPL-3"
  17. SLOT="0"
  18. IUSE="examples static-libs"
  19. RDEPEND=""
  20. DEPEND="${RDEPEND}
  21. virtual/pkgconfig"
  22. S="${WORKDIR}/${PN}-${P}"
  23. PATCHES=(
  24. "${FILESDIR}"/${PN}-1.9.5-headers.patch
  25. "${FILESDIR}"/${PN}-1.9.5-implicit-internal.patch
  26. )
  27. src_install() {
  28. autotools-utils_src_install
  29. if use examples; then
  30. # --enable-examples configure switch just compiles them
  31. # better install sources instead
  32. exeinto /usr/share/doc/${PF}/examples/
  33. for program in $(grep PROGRAMS examples/Makefile.am | cut -d= -f2); do
  34. doexe examples/${program}.c
  35. done
  36. fi
  37. }