weex-2.6.1.5-r1.ebuild 648 B

1234567891011121314151617181920212223242526272829303132
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils
  5. DESCRIPTION="Automates maintaining a web page or other FTP archive"
  6. HOMEPAGE="http://weex.sourceforge.net/"
  7. SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 ~ppc x86"
  11. IUSE="" #nls
  12. DEPEND="sys-libs/ncurses"
  13. src_prepare() {
  14. epatch "${FILESDIR}/${P}-va_list.patch"
  15. epatch "${FILESDIR}/formatstring.patch"
  16. }
  17. src_configure() {
  18. econf --disable-nls #532502
  19. }
  20. src_install() {
  21. default
  22. dodoc doc/TODO* doc/README* doc/FAQ* doc/sample* doc/ChangeLog* \
  23. doc/BUG* doc/THANK*
  24. }