irssi-xmpp-0.52.ebuild 776 B

123456789101112131415161718192021222324252627282930313233343536
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. inherit toolchain-funcs multilib
  5. DESCRIPTION="An irssi plugin providing Jabber/XMPP support"
  6. HOMEPAGE="http://cybione.org/~irssi-xmpp/"
  7. SRC_URI="http://cybione.org/~${PN}/files/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 x86"
  11. IUSE=""
  12. DEPEND="<net-irc/irssi-1
  13. >=net-libs/loudmouth-1.4.0[debug]"
  14. RDEPEND="${DEPEND}"
  15. src_prepare() {
  16. sed -e "s/{MAKE} doc-install/{MAKE}/" \
  17. -i Makefile || die #322355
  18. sed -e "/^CFLAGS\|LDFLAGS/ s/=/+=/" \
  19. -i config.mk || die
  20. }
  21. src_compile() {
  22. emake PREFIX=/usr CC="$(tc-getCC)"
  23. }
  24. src_install() {
  25. emake DESTDIR="${D}" PREFIX=/usr IRSSI_LIB=/usr/$(get_libdir)/irssi install
  26. dodoc README NEWS TODO docs/*
  27. }