irssi-xmpp-0.53.ebuild 794 B

123456789101112131415161718192021222324252627282930313233343536373839
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit toolchain-funcs
  5. DESCRIPTION="An irssi plugin providing Jabber/XMPP support"
  6. HOMEPAGE="https://cybione.org/~irssi-xmpp/"
  7. SRC_URI="https://github.com/cdidier/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. IUSE=""
  12. DEPEND="
  13. >=net-irc/irssi-0.8.13
  14. >=net-libs/loudmouth-1.4.0"
  15. RDEPEND="${DEPEND}"
  16. PATCHES=( "${FILESDIR}/${P}-irssi-1.0.patch" )
  17. src_prepare() {
  18. default
  19. sed -e "s/{MAKE} doc-install/{MAKE}/" \
  20. -i Makefile || die #322355
  21. }
  22. src_compile() {
  23. emake PREFIX=/usr CC="$(tc-getCC)"
  24. }
  25. src_install() {
  26. emake DESTDIR="${D}" PREFIX=/usr IRSSI_LIB=/usr/$(get_libdir)/irssi install
  27. dodoc README NEWS TODO docs/*
  28. }