asmail-2.1.ebuild 963 B

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. inherit toolchain-funcs eutils
  4. DESCRIPTION="a small mail monitor similar to xbiff"
  5. HOMEPAGE="http://www.tigr.net"
  6. SRC_URI="http://www.tigr.net/afterstep/download/${PN}/${P}.tar.gz"
  7. LICENSE="GPL-2"
  8. SLOT="0"
  9. KEYWORDS="~amd64 ~ppc x86"
  10. IUSE="jpeg"
  11. RDEPEND="dev-libs/openssl
  12. x11-libs/libXext
  13. x11-libs/libX11
  14. x11-libs/libXpm
  15. x11-libs/libICE
  16. x11-libs/libSM
  17. jpeg? ( virtual/jpeg )"
  18. DEPEND="${RDEPEND}
  19. x11-proto/xextproto"
  20. src_compile() {
  21. epatch "${FILESDIR}"/${P}-ldflags.patch
  22. sed -i -e "/LIB/s/-lssl/-lssl -lcrypto/g" \
  23. configure
  24. tc-export CC
  25. econf $(use_enable jpeg)
  26. emake || die "emake failed."
  27. }
  28. src_install() {
  29. dobin ${PN}
  30. newman ${PN}.man ${PN}.1
  31. newman ${PN}rc.man ${PN}rc.5
  32. insinto /usr/share/${PN}/pixmaps
  33. doins pixmaps/cloud-e/*.xpm
  34. insinto /usr/share/${PN}
  35. doins -r sounds
  36. dodoc ${PN}rc.s* CHANGES *.txt README* TODO
  37. }