email-2.5.0.ebuild 1.0 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. DESCRIPTION="Advanced CLI tool for sending email"
  4. HOMEPAGE="http://email.cleancode.org"
  5. SRC_URI="http://email.cleancode.org/download/${P}.tar.bz2"
  6. LICENSE="GPL-2"
  7. SLOT="0"
  8. KEYWORDS="alpha amd64 x86"
  9. IUSE=""
  10. DEPEND=""
  11. RDEPEND="${DEPEND}"
  12. src_compile() {
  13. local myconf=""
  14. if [ -f /etc/conf.d/clock ]; then
  15. . /etc/conf.d/clock
  16. if [ x$CLOCK = "xUTC" ]; then
  17. elog "Using UTC timestamps (from /etc/conf.d/clock)"
  18. myconf="${myconf} --with-utc"
  19. fi
  20. fi
  21. sed -i -e "s:/doc/email-\${version}:/share/doc:" configure
  22. sed -i -e "s:DIVIDER = '---':DIVIDER = '-- ':" email.conf
  23. econf ${myconf} || die "econf failed"
  24. emake || die "emake failed"
  25. }
  26. src_install() {
  27. doman email.1
  28. dodoc INSTALL quoted-printable.rfc RFC821 TODO
  29. make DESTDIR="${D}" install || die "install failed"
  30. }
  31. pkg_preinst() {
  32. rm "${D}"/usr/share/doc/"${P}"/email.1
  33. }
  34. pkg_postinst() {
  35. echo
  36. elog "Do not forget to edit /etc/email/email.conf file before using email."
  37. echo
  38. }