fastforward-0.51-r1.ebuild 943 B

1234567891011121314151617181920212223242526272829303132333435363738394041424344
  1. # Copyright 1999-2012 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. inherit eutils fixheadtails
  4. DESCRIPTION="handle qmail forwarding according to a cdb database"
  5. HOMEPAGE="http://cr.yp.to/fastforward.html"
  6. SRC_URI="http://cr.yp.to/software/${P}.tar.gz"
  7. LICENSE="public-domain"
  8. SLOT="0"
  9. KEYWORDS="x86 sparc ~ppc"
  10. IUSE=""
  11. DEPEND="sys-apps/groff"
  12. src_unpack() {
  13. unpack ${A}
  14. cd "${S}"
  15. epatch "${FILESDIR}/${PV}-errno.patch"
  16. ht_fix_file Makefile
  17. echo "gcc ${CFLAGS}" > conf-cc
  18. echo "gcc" > conf-ld
  19. }
  20. src_compile() {
  21. emake it || die
  22. }
  23. # make check is actually an install-check target, see bug #283177
  24. src_test() { :; }
  25. src_install() {
  26. dodoc ALIASES BLURB CHANGES FILES INSTALL README SYSDEPS TARGETS
  27. dodoc THANKS TODO VERSION
  28. doman *.1
  29. insopts -o root -g qmail -m 755
  30. insinto /var/qmail/bin
  31. doins fastforward newaliases newinclude printforward printmaillist \
  32. setforward setmaillist
  33. }