gnubiff-2.2.15-r2.ebuild 1.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit autotools eutils
  5. DESCRIPTION="A mail notification program"
  6. HOMEPAGE="http://gnubiff.sourceforge.net/"
  7. SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
  8. LICENSE="GPL-3"
  9. SLOT="0"
  10. KEYWORDS="amd64 x86"
  11. IUSE="debug fam nls password"
  12. RDEPEND="
  13. >=x11-libs/gtk+-3:3
  14. >=gnome-base/libglade-2.3
  15. dev-libs/popt
  16. password? ( dev-libs/openssl )
  17. fam? ( virtual/fam )
  18. x11-proto/xproto
  19. x11-libs/libX11
  20. x11-libs/pango
  21. x11-libs/gdk-pixbuf
  22. "
  23. DEPEND="${RDEPEND}
  24. virtual/pkgconfig
  25. "
  26. DOCS="AUTHORS ChangeLog NEWS README THANKS TODO"
  27. src_prepare() {
  28. epatch \
  29. "${FILESDIR}"/${P}-fix-nls.patch \
  30. "${FILESDIR}"/${P}-gold.patch \
  31. "${FILESDIR}"/${P}-underlink.patch
  32. eautoreconf
  33. }
  34. src_configure() {
  35. # note: --disable-gnome is to avoid deprecated gnome-panel-2.x
  36. econf \
  37. --disable-gnome \
  38. $(use_enable debug) \
  39. $(use_enable nls) \
  40. $(use_enable fam) \
  41. $(use_with password) \
  42. $(use_with password password-string ${RANDOM}${RANDOM}${RANDOM}${RANDOM})
  43. }