mairix-0.23.ebuild 1.1 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950
  1. # Copyright 1999-2012 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. inherit toolchain-funcs eutils
  5. DESCRIPTION="Indexes and searches Maildir/MH folders"
  6. HOMEPAGE="http://www.rpcurnow.force9.co.uk/mairix/"
  7. SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
  8. gnus? ( mirror://gentoo/${P}-gnus-marks-propagation.patch.gz )"
  9. LICENSE="GPL-2"
  10. SLOT="0"
  11. KEYWORDS="amd64 ppc x86 ~x86-macos"
  12. IUSE="zlib bzip2 gnus"
  13. RDEPEND="zlib? ( sys-libs/zlib )
  14. bzip2? ( app-arch/bzip2 )"
  15. DEPEND="${RDEPEND}
  16. sys-devel/flex
  17. sys-devel/bison"
  18. # Fail on various locales
  19. RESTRICT="test"
  20. src_prepare() {
  21. # econf would fail with unknown options.
  22. # Now it only prints "Unrecognized option".
  23. sed -i -e "/^[[:space:]]*bad_options=yes/d" "${S}"/configure || die "sed failed"
  24. # Add support for gnus marks propagation (bug #274578)
  25. use gnus && epatch "${WORKDIR}"/${P}-gnus-marks-propagation.patch
  26. }
  27. src_configure() {
  28. tc-export CC
  29. econf \
  30. $(use_enable zlib gzip-mbox) \
  31. $(use_enable bzip2 bzip-mbox)
  32. }
  33. src_install() {
  34. dobin mairix
  35. doman mairix.1 mairixrc.5
  36. dodoc NEWS README dotmairixrc.eg
  37. }