mhonarc-gentoo-2.6.18-r2.ebuild 750 B

1234567891011121314151617181920212223242526272829
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit perl-module
  5. DESCRIPTION="Perl Mail-to-HTML Converter, Gentoo fork"
  6. HOMEPAGE="http://www.mhonarc.org/"
  7. LICENSE="GPL-2"
  8. SRC_URI="http://www.mhonarc.org/release/MHonArc/tar/MHonArc-${PV}.tar.bz2"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. RDEPEND="!net-mail/mhonarc"
  12. MY_P="${P/mhonarc-gentoo/MHonArc}"
  13. S="${WORKDIR}/${MY_P}"
  14. PATCHES=( "${FILESDIR}/${P}-archives-gentoo.patch" )
  15. src_install() {
  16. sed -e "s|-prefix |-docpath '${D}/usr/share/doc/${PF}' -prefix '${D}'|g" -i Makefile || die "sed on Makefile failed"
  17. sed -e "s|installsitelib|installvendorlib|g" -i install.me || die "sed on install.me failed"
  18. perl-module_src_install
  19. }