mpop-1.2.5.ebuild 1.1 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. DESCRIPTION="A small, fast, and portable POP3 client"
  5. HOMEPAGE="http://mpop.sourceforge.net/"
  6. SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
  7. LICENSE="GPL-3"
  8. SLOT="0"
  9. KEYWORDS="~amd64 ~arm ~x86"
  10. IUSE="gnutls idn libressl libsecret nls sasl ssl vim-syntax"
  11. RDEPEND="
  12. idn? ( net-dns/libidn )
  13. libsecret? ( app-crypt/libsecret )
  14. nls? ( virtual/libintl )
  15. sasl? ( virtual/gsasl )
  16. ssl? (
  17. gnutls? ( net-libs/gnutls )
  18. !gnutls? (
  19. !libressl? ( dev-libs/openssl:0= )
  20. libressl? ( dev-libs/libressl:0= )
  21. )
  22. )"
  23. DEPEND="${RDEPEND}
  24. nls? ( sys-devel/gettext )
  25. virtual/pkgconfig"
  26. REQUIRED_USE="gnutls? ( ssl )"
  27. DOCS="AUTHORS ChangeLog NEWS NOTES README THANKS"
  28. src_configure() {
  29. econf \
  30. $(use_enable nls) \
  31. $(use_with ssl ssl $(usex gnutls "gnutls" "openssl")) \
  32. $(use_with sasl libgsasl) \
  33. $(use_with idn libidn) \
  34. $(use_with libsecret )
  35. }
  36. src_install() {
  37. default
  38. if use vim-syntax ; then
  39. insinto /usr/share/vim/vimfiles/syntax
  40. doins scripts/vim/mpop.vim
  41. fi
  42. }